Problema Con Windows/system32/config/system

Estándar

Problema:

NO SE HA INICIADO WINDOWS PORQUE EL SIGUIENTE ARCHIVO FALTA O ESTA DAÑADO:
\WINDIWS\SYSTEM32\CONFIG\SYSTEM
PARA REPARAR ESTE ARCHIVO INICIE EL PROGRAMA DE INSTALACION DE WINDOWS DESDE EL DISQUETE O CD-ROM ORIGINAL.
PRESIONE “R” EN LA PRIMERA PANTALLA PARA INICIAR LA REPARACION.

 

Solucion:

CD \WINDOWS\SYSTEM32\CONFIG
DEL system
Copy C:\WINDOWS\REPAIR\system C:\WINDOWS\SYSTEM32\CONFIG

 

Esto no es nada nuevo, pero pretendo que sea recordatorio para otra ocacion y no andar buscando como loco je je je

Unable to resolve target ‘android-X’

Estándar

Revisando ejemplos de código para android me tope con ese error “Unable to resolve target ‘android-4′” investigando un poco logre descubrir la causa y su solución

Aquí están las variantes del error

Unable to resolve target ‘android-1’
Unable to resolve target ‘android-2’
Unable to resolve target ‘android-3’
Unable to resolve target ‘android-4’
Unable to resolve target ‘android-5’
Unable to resolve target ‘android-6’
Unable to resolve target ‘android-7’
Unable to resolve target ‘android-8’
Unable to resolve target ‘android-9’
Unable to resolve target ‘android-10’
Unable to resolve target ‘android-11’
Unable to resolve target ‘android-12’
Unable to resolve target ‘android-13’
Unable to resolve target ‘android-14’
Unable to resolve target ‘android-15’

El motivo es que no tenemos instalada la versión adecuada del SDK de android

Unable to resolve target ‘android-1’ – (Android 1.0) change the”default.properties”
Unable to resolve target ‘android-2’ – (Android 1.1) change the “default.properties”
Unable to resolve target ‘android-3’ – instala SDK  Android 1.5
Unable to resolve target ‘android-4’ – instala SDK Android 1.6
Unable to resolve target ‘android-5’ – instala SDK Android 2.0
Unable to resolve target ‘android-6’ – instala SDK Android 2.0.1
Unable to resolve target ‘android-7’ – instala SDK Android 2.1
Unable to resolve target ‘android-8’ – instala SDK Android 2.2
Unable to resolve target ‘android-9’ – instala SDK Android 2.3
Unable to resolve target ‘android-10’ – instala SDK Android 2.3.3
Unable to resolve target ‘android-11’ – instala SDK Android 3.0
Unable to resolve target ‘android-12’ – instala  SDK Android 3.1
Unable to resolve target ‘android-13’ – instala SDK Android 3.2
Unable to resolve target ‘android-14’ – instala SDK Android 4.0
Unable to resolve target ‘android-15’ – instala SDK Android 4.0.3

 

fuente : http://sagistech.blogspot.com/2010/05/android-sdk-error-unable-to-resolve.html

PhoneGap – Para aplicaciones multiplataforma

Estándar

Estos dias que me puse a estar experimentando en el desarrollo de dispositivos móviles conocí otras maneras interesantes de trabajar con android como PhoneGap que nos permite crear aplicaciones nativas para varias plataformas como Android, iOS, BlacBerry,WindowsPhone7, Bada entre otros, aquí hay un pequeño manual para hacer aplicaciones android con PhoneGap en español, este sistema trabaja usando HTML5, CSS3 y Javascript ejecutadas en un componente Webkit del teléfono , se provee una librería desarrollada en el lenguaje especifico de cada plataforma que nos permiten acceder a las caracteristicas de cada telefono como es la camara, el GPS, acelerometro, contactos, sistema de archivos y más. Al ser una pagina web tenemos acceso al DOM y podemos usar frameworks web como jQuery mobile y Sencha Touch

OCR en Linux

Estándar

Estos días me puse a pasar unas hojas de estadística a formato ODT y lo mas frustrante es copiar todas esas lineas a la computadora y mas cuando tu velocidad con el teclado no es nada rapida, lo mejor es usar un software que se encargue de eso, y precisamente para eso esta Tesseract, Tesseract es un motor OCR libre. Fue desarrollado originalmente por HP como software propietario. Tras diez años sin ningún desarrollo fue liberado, Tesseract es desarrollado actualmente por Google.

Este programa trabaja desde consola y en verdad es muy potente y preciso solo necesitamos:

-tesseract-ocr
-imagemagick Continuar leyendo

Centrar una ventana en Java

Estándar

Si en alguna ocacion necesitas centrar un jFrame de java aqui esta el método, solo lo tienes que agregar al evento WidowOpened y tendras tu ventana  centrada en un abrir y cerrar de ojos


protected void this_windowOpened(WindowEvent e) {
                centrarVentana();
        }

        private void centrarVentana() {
                // Se obtienen las dimensiones en pixels de la pantalla.
                Dimension pantalla = Toolkit.getDefaultToolkit().getScreenSize();

                // Se obtienen las dimensiones en pixels de la ventana.
                Dimension ventana = getSize();

                // Una cuenta para situar la ventana en el centro de la pantalla.
setLocation((pantalla.width – ventana.width) / 2,
(pantalla.height – ventana.height) / 2);
}

Instalar Adobe Flash Player en Linux de 64 bits

Estándar

Instalar Adobe Flash Player en Linux de 64 bits es más fácil de lo que te imaginas, lo primero que tienes que hacer es descargar este paquete tar.gz de la página oficial de Adobe que tiene el plugin para x86_64.

Lo siguiente que hay que hacer es descomprimir este  paquete con la siguiente instrucción

tar xvzf flashplayer10_2_p3_64bit_linux_111710.tar.gz

el nombre tal vez pueda cambiar un poco pero en esencia es  así…

Una vez con el archivo extraído solo hay que copiarlo a la carpeta correspondiente, el archivo que hay que copiar se llama libflashplayer.so

y se pasa con esta linea

# cp /home/Usuario/Descargas/libflashplayer.so /usr/lib64/mozilla/plugins/

En Ubuntu está en  /usr/lib64/flashplugin-installer/

En Opensuse en  /usr/lib64/browser-plugins/

En Fedora en  /usr/lib64/mozilla/plugins/

Y listo solo tenemos que reiniciar firefox y ya podremos disfrutar de flash

Hay que mencionar que este plugin es versión de prueba, pero aun así va de maravilla